Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-ceph_git.bb
1
2 SUMMARY = "Community Developed Ceph Module."
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=0e5ccf641e613489e66aa98271dbe798"
6
7 PV = "2.4.1"
8 SRCREV = "ebea4b703d002d64d0b623cc51d42890b187ab97"
9 PROTOCOL = "https"
10 BRANCH = "stable/jewel"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = "git://github.com/openstack/puppet-ceph.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
14         file://puppet-ceph/Add-gemspec.patch \
15         "
16
17 inherit ruby
18
19 DEPENDS += " \
20         ruby \
21         facter \
22         "
23
24 RDEPENDS_${PN} += " \
25         ruby \
26         facter \
27         puppet \
28         perl \
29         "
30
31 RUBY_INSTALL_GEMS = "puppet-ceph-${PV}.gem"
32
33 do_install_append() {
34         install -d -m 0755 ${D}/${datadir}/puppet/modules/ceph
35         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/ceph
36 }
37
38 FILES_${PN} += " ${datadir}"