Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-boolean_git.bb
1
2 DESCRIPTION = "Logical Resource Management (LVM) features for Puppet."
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=8cbd44f4ffbc81632df22fdd4ae87811"
6
7 PV = "1.0.1"
8 SRCREV = "22b726dd78b0a60a224cc7054aebbf28e9306f62"
9 PROTOCOL = "https"
10 BRANCH = "master"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = "git://github.com/adrienthebo/puppet-boolean;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
14         file://${PN}/Add-gemspec.patch \
15         "
16 inherit ruby
17
18 DEPENDS += " \
19         ruby \
20         facter \
21         "
22
23 RDEPENDS_${PN} += " \
24         ruby \
25         facter \
26         puppet \
27         perl \
28         "
29
30 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
31
32
33 do_install_append() {
34         install -d -m 0755 ${D}/${datadir}/puppet/modules/boolean
35         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/boolean/
36 }
37
38 FILES_${PN} += " ${datadir}"