Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-barbican_git.bb
1
2 SUMMARY = "Puppet module for OpenStack Barbican"
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=fce88ac1cd1315adf28a52502c9f7f6b"
6
7 RDEPENDS_${PN} += " \
8         puppetlabs-inifile \
9         "
10
11 PV = "11.3.0"
12 SRCREV = "8241a1d13be6c3ee6344fa46dcfc045439044e76"
13 PROTOCOL = "https"
14 S = "${WORKDIR}/git"
15
16 SRC_URI = "git://github.com/openstack/puppet-barbican.git;protocol=${PROTOCOL};rev=${SRCREV};nobranch=1 \
17         file://puppet-barbican/Add-gemspec.patch \
18         "
19
20 inherit ruby
21
22 DEPENDS += " \
23         ruby \
24         facter \
25         "
26
27 RDEPENDS_${PN} += " \
28         ruby \
29         facter \
30         puppet \
31         perl \
32         "
33
34 RUBY_INSTALL_GEMS = "puppet-barbican-${PV}.gem"
35
36 do_install_append() {
37         install -d -m 0755 ${D}/${datadir}/puppet/modules/barbican
38         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/barbican
39 }
40
41 FILES_${PN} += " ${datadir}"