Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / os-service-types / python2-os-service-types_1.3.0.bb
1
2 DESCRIPTION = "A library to handle official service types for OpenStack and their historical aliases."
3 HOMEPAGE = "https://opendev.org/openstack/os-service-types"
4 SECTION = "devel/python"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 STABLE = "master"
9 PROTOCOL = "https"
10 BRANCH = "master"
11 SRCREV = "2e5b38088a43539621de82aa2d0c1b366c2638a9"
12 S = "${WORKDIR}/git"
13
14 SRC_URI = "git://opendev.org/openstack/os-service-types.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
15
16 inherit setuptools 
17
18 DEPENDS += " \
19         python-pip \
20         python-pbr-native \
21         "
22
23 RDEPENDS_${PN} += " \
24         python-lxml \
25         python-requests \
26         python-cython \
27         "