Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / ldapscripts / ldapscripts_2.0.8.bb
1
2 DESCRIPTION = " \
3 The ldapscripts are originally designed to be used within Samba 3.x's \
4 smb.conf file. They allow to manipulate POSIX entries for users, groups \
5 and machines in an LDAP directory. They are written in shell and need ldap \
6 client commands to work correctly (ldapadd, ldapdelete, ldapmodify, \
7 ldapsearch). Other scripts also are provided as simple tools to (manually) \
8 query your LDAP directory : ldapfinger, ldapid, lsldap (...). \
9  \
10 They are designed to be used under GNU/Linux or FreeBSD (any other \
11 recent UNIX-like should also work) and require several binaries that should \
12 come with your OS (uuencode, getent/pw, date, grep, sed, cut...). \
13  \
14 Latest version available on http://contribs.martymac.org \
15 "
16
17 SUMMARY = "Shell scripts to manage POSIX accounts in LDAP"
18
19 SECTION = "base"
20 LICENSE = "GPLv2"
21
22 LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
23
24 SRC_URI = "https://downloads.sourceforge.net/project/ldapscripts/ldapscripts/ldapscripts-2.0.8/ldapscripts-2.0.8.tgz"
25 SRC_URI[md5sum] = "99a7222215eaea2c8bc790d0437f22ea"
26 SRC_URI[sha256sum] = "7db3848501f257a10417c9bcfc0b70b76d0a8093eb993f2354925e156c3419ff"
27
28 SRC_URI += " file://sudo-support.patch \
29              file://sudo-delete-support.patch \
30              file://log_timestamp.patch \
31              file://ldap-user-setup-support.patch \
32              file://allow-anonymous-bind-for-ldap-search.patch \
33              file://ldapscripts.conf.cgcs \
34         file://ldapadduser.template.cgcs \
35         file://ldapaddgroup.template.cgcs \
36         file://ldapmoduser.template.cgcs \
37         file://ldapaddsudo.template.cgcs \
38         file://ldapmodsudo.template.cgcs \
39         file://ldapscripts.passwd \
40 "
41
42 SOURCE1 = "${WORKDIR}/ldapscripts.conf.cgcs"
43 SOURCE2 = "${WORKDIR}/ldapadduser.template.cgcs"
44 SOURCE3 = "${WORKDIR}/ldapaddgroup.template.cgcs"
45 SOURCE4 = "${WORKDIR}/ldapmoduser.template.cgcs"
46 SOURCE5 = "${WORKDIR}/ldapaddsudo.template.cgcs"
47 SOURCE6 = "${WORKDIR}/ldapmodsudo.template.cgcs"
48 SOURCE7 = "${WORKDIR}/ldapscripts.passwd"
49
50 do_configure () {
51         cd ${S}
52         oe_runmake -e configure
53 }
54
55 do_compile () {
56         :
57 }
58
59 do_install () {
60         cd ${S}
61         oe_runmake -e DESTDIR=${D} SBINDIR=${sbindir} \
62                 MANDIR=${mandir} ETCDIR=${sysconfdir}/ldapscripts \
63                 LIBDIR=${libdir} install
64
65         rm -Rf ${D}${mandir}/*
66         rm -f ${D}${sbindir}/*machine*
67         rm -f ${D}${sysconfdir}//ldapscripts/ldapaddmachine.template.sample
68         install -m 644 ${SOURCE1} ${D}${sysconfdir}/ldapscripts/ldapscripts.conf
69         install -m 644 ${SOURCE2} ${D}${sysconfdir}/ldapscripts/ldapadduser.template.cgcs
70         install -m 644 ${SOURCE3} ${D}${sysconfdir}/ldapscripts/ldapaddgroup.template.cgcs
71         install -m 644 ${SOURCE4} ${D}${sysconfdir}/ldapscripts/ldapmoduser.template.cgcs
72         install -m 644 ${SOURCE5} ${D}${sysconfdir}/ldapscripts/ldapaddsudo.template.cgcs
73         install -m 644 ${SOURCE6} ${D}${sysconfdir}/ldapscripts/ldapmodsudo.template.cgcs
74         install -m 600 ${SOURCE7} ${D}${sysconfdir}/ldapscripts/ldapscripts.passwd
75 }
76
77 FILES_${PN}_append = " ${libdir}/runtime \
78                        ${sysconfdir} \
79 "