Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-devtools / erlang / erlang_R16B03-1.bbappend
1
2 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4 # erlang < 20.0 is not compatibel with OpenSSL 1.1.x
5 inherit openssl10
6
7 SRC_URI += " \
8         file://fix-install-ownership.patch \
9         "
10
11 EXTRA_OECONF = '--with-ssl=${STAGING_DIR_TARGET}/usr --without-krb5 --without-zlib'
12
13 do_configure_prepend () {
14     export erl_xcomp_sysroot="${STAGING_DIR_HOST}/usr"
15     export erl_xcomp_isysroot="${STAGING_DIR_NATIVE}"
16
17     sed -i -e 's/opensslconf.h/opensslconf-64.h/' \
18         ${STAGING_INCDIR}/openssl10/openssl/rc4.h \
19         ${STAGING_INCDIR}/openssl10/openssl/rc2.h
20 }
21
22 do_install_append () {
23     # Fix the do_package_qa issue
24     chown -R root:root ${D}
25 }