Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-connectivity / qpid / qpid-proton_0.28.0.bb
1
2 DESCRIPTION = "Qpid Proton is a high-performance, lightweight messaging library."
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b26578452df1dcf3b9a63978282b72d0"
5
6 SRC_URI = "http://archive.apache.org/dist/qpid/proton/0.28.0/qpid-proton-0.28.0.tar.gz \
7            file://fix-missing-libary-for-cpp-binding.patch \
8           "
9
10 SRC_URI[sha256sum] = "224e599a4e965a016087b6ce683e55ca918493e12cdd6d91dac1c17d64a7dafe"
11
12 DEPENDS= "openssl swig-native python"
13
14 inherit cmake pkgconfig
15
16 EXTRA_OECMAKE = "-DCMAKE_INSTALL_PREFIX=/usr -DSYSINSTALL_BINDINGS=ON -DPYTHON_EXECUTABLE=`which python`"
17 BBCLASSEXTEND =+ " native"
18
19 PACKAGES =+ "\
20          ${PN}-cpp \
21          python-${PN} \
22          "
23
24 #FILES_qpid-proton-c = "${libdir}/libqpid-proton.so.*" 
25 #FILES_qpid-proton-c += "{libdir}/libqpid-proton-core.so.*" 
26 #FILES_qpid-proton-c += "${libdir}/libbqpid-proton-proactor.so.*" 
27
28 FILES_qpid-proton-cpp = "${libdir}/libqpid-proton-cpp.so.*" 
29 FILES_python-${PN} = "${libdir}/python*" 
30
31 RPROVIDES_${PN} = "qpid-proton-c"
32
33 do_install_append() {
34          rm -fr ${D}/usr/share
35 }