Initial commit of the O1 simulator framework.
[sim/o1-interface.git] / ntsimulator / src / o-ran-notifications / CMakeLists.txt
diff --git a/ntsimulator/src/o-ran-notifications/CMakeLists.txt b/ntsimulator/src/o-ran-notifications/CMakeLists.txt
new file mode 100644 (file)
index 0000000..d915ca2
--- /dev/null
@@ -0,0 +1,17 @@
+set (NOTIFICATIONS_SOURCES
+    o-ran-notifications.c
+)
+
+include_directories(
+    "/usr/include/x86_64-linux-gnu"
+    "/usr/local/include/cjson"
+)
+
+add_executable(o-ran-notifications ${NOTIFICATIONS_SOURCES})
+target_link_libraries(o-ran-notifications utils)
+target_link_libraries(o-ran-notifications sysrepo)
+target_link_libraries(o-ran-notifications m)
+target_link_libraries(o-ran-notifications curl)
+target_link_libraries(o-ran-notifications cjson)
+
+install(TARGETS o-ran-notifications DESTINATION ${CMAKE_INSTALL_BINDIR})
\ No newline at end of file