Add simulator improvements.
[sim/o1-interface.git] / ntsimulator / src / generic-notifications / CMakeLists.txt
diff --git a/ntsimulator/src/generic-notifications/CMakeLists.txt b/ntsimulator/src/generic-notifications/CMakeLists.txt
new file mode 100644 (file)
index 0000000..c87e843
--- /dev/null
@@ -0,0 +1,19 @@
+set (NOTIFICATIONS_SOURCES
+    generic-notifications.c
+)
+
+include_directories(
+    "/usr/include/x86_64-linux-gnu"
+    "/usr/local/include/cjson"
+    "/usr/local/include/libyang"
+)
+
+add_executable(generic-notifications ${NOTIFICATIONS_SOURCES})
+target_link_libraries(generic-notifications utils)
+target_link_libraries(generic-notifications sysrepo)
+target_link_libraries(generic-notifications m)
+target_link_libraries(generic-notifications curl)
+target_link_libraries(generic-notifications cjson)
+target_link_libraries(generic-notifications yang)
+
+install(TARGETS generic-notifications DESTINATION ${CMAKE_INSTALL_BINDIR})
\ No newline at end of file