RIC-641 Add client/server model definitions
[ric-plt/xapp-frame-cpp.git] / src / rest / CMakeLists.txt
diff --git a/src/rest/CMakeLists.txt b/src/rest/CMakeLists.txt
new file mode 100644 (file)
index 0000000..282e9b9
--- /dev/null
@@ -0,0 +1,27 @@
+# vim: sw=4 ts=4 noet:
+#
+#==================================================================================
+#   Copyright (c) 2020 Nokia
+#   Copyright (c) 2020 AT&T Intellectual Property.
+#
+#   Licensed under the Apache License, Version 2.0 (the "License");
+#   you may not use this file except in compliance with the License.
+#   You may obtain a copy of the License at
+#
+#       http://www.apache.org/licenses/LICENSE-2.0
+#
+#   Unless required by applicable law or agreed to in writing, software
+#   distributed under the License is distributed on an "AS IS" BASIS,
+#   WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#   See the License for the specific language governing permissions and
+#   limitations under the License.
+#==================================================================================
+#
+
+
+# For clarity: this generates object, not a lib as the CM command implies.
+#
+add_subdirectory(./model)
+#add_subdirectory(./clientapi)
+#add_subdirectory(./serverapi)
+