Update TS xApp for Release E use case
[ric-app/ts.git] / test / app / CMakeLists.txt
index ffd4cee..5d3eac2 100644 (file)
 #    limitations under the License.
 # ==================================================================================
 #
-#      Mnemonic: ad_xapp.cpp
-#      Abstract: Simulates the AD xApp sending an anomaly dectection message to
-#             the TS xApp. It sends one message and exits.
-#
 #      Date:     20 May 2021
 #      Author:   Alexandre Huff
 
 
 cmake_minimum_required(VERSION 3.14)
+project(test_apps)
 set(CMAKE_CXX_STANDARD 11)
 
 add_executable(
@@ -49,3 +46,16 @@ target_link_libraries(
   pthread
   curl
 )
+
+find_package(Protobuf REQUIRED)
+add_subdirectory(${CMAKE_SOURCE_DIR}/../../ext/protobuf EXCLUDED_FROM_ALL)
+add_executable(
+  rc_xapp
+  rc_xapp.cpp
+)
+target_link_libraries(
+  rc_xapp
+  rc-api
+  grpc++
+  ${Protobuf_LIBRARY}
+)