Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppetlabs-stdlib_git.bbappend
diff --git a/meta-stx/recipes-support/puppet/puppetlabs-stdlib_git.bbappend b/meta-stx/recipes-support/puppet/puppetlabs-stdlib_git.bbappend
new file mode 100644 (file)
index 0000000..7003fce
--- /dev/null
@@ -0,0 +1,58 @@
+#
+## Copyright (C) 2019 Wind River Systems, Inc.
+#
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
+#
+# Copyright (C) 2019 Wind River Systems, Inc.
+#
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRCREV = "b89d5f388ca701e38a0e0337408f5ccb7e68565f"
+PROTOCOL = "https"
+BRANCH = "master"
+PV = "4.18.0"
+
+SRC_URI = " \
+       git://github.com/puppetlabs/puppetlabs-stdlib.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
+       file://puppetlabs-stdlib/Add-gemspec.patch \
+       file://puppetlabs-stdlib/0001-Filter-password-in-logs.patch \
+       "
+
+S = "${WORKDIR}/git"
+
+RUBY_INSTALL_GEMS = "puppetlabs-stdlib-${PV}.gem"
+
+do_install_append () {
+       install -d -m 0755 ${D}/${datadir}/puppet/modules/stdlib
+       tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/stdlib
+}
+
+FILES_${PN} += " ${datadir}"
+
+RDEPENDS_${PN}_append = " perl"