Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-vswitch_%.bbappend
diff --git a/meta-stx/recipes-support/puppet/puppet-vswitch_%.bbappend b/meta-stx/recipes-support/puppet/puppet-vswitch_%.bbappend
new file mode 100644 (file)
index 0000000..e4cec84
--- /dev/null
@@ -0,0 +1,25 @@
+#
+## Copyright (C) 2019 Wind River Systems, Inc.
+#
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+do_install_append() {
+       install -d -m 0755 ${D}/${datadir}/puppet/modules/vswitch
+       tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/vswitch
+}
+
+FILES_${PN} += " ${datadir}"
+
+inherit openssl10
+RDEPENDS_${PN}_append = " perl"