meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-sysctl_git.bb
diff --git a/meta-stx/recipes-support/puppet/puppet-sysctl_git.bb b/meta-stx/recipes-support/puppet/puppet-sysctl_git.bb
deleted file mode 100644 (file)
index cfea440..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-#
-# Copyright (C) 2019 Wind River Systems, Inc.
-#
-#  Licensed under the Apache License, Version 2.0 (the "License");
-#  you may not use this file except in compliance with the License.
-#  You may obtain a copy of the License at
-#
-#      http://www.apache.org/licenses/LICENSE-2.0
-#
-#  Unless required by applicable law or agreed to in writing, software
-#  distributed under the License is distributed on an "AS IS" BASIS,
-#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-#  See the License for the specific language governing permissions and
-#  limitations under the License.
-
-SUMMARY = "This modules allows you to configure sysctl."
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://README.md;md5=b5335702ab6b120493cf88faaf9be346"
-
-PV = "0.0.11"
-SRCREV = "65ffe839a4ce785bc3901452488197a0ef158cd8"
-PROTOCOL = "https"
-BRANCH = "master"
-S = "${WORKDIR}/git"
-
-SRC_URI = "git://github.com/duritong/puppet-sysctl;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
-       file://${PN}/Add-gemspec.patch \
-       "
-
-inherit ruby
-
-DEPENDS += " \
-       ruby \
-       facter \
-       "
-
-RDEPENDS_${PN} += " \
-       ruby \
-       facter \
-       puppet \
-       perl \
-       "
-
-RUBY_BUILD_GEMS = "duritong-sysctl.gemspec"
-RUBY_INSTALL_GEMS = "duritong-sysctl-${PV}.gem"
-
-do_install_append() {
-       install -d -m 0755 ${D}/${datadir}/puppet/modules/sysctl
-       tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/sysctl
-}
-
-FILES_${PN} += " ${datadir}"