build_inf.sh: change the protocal for github repo
[pti/rtp.git] / meta-stx / recipes-kernel / linux / kernel-devsrc.bbappend
index 5f8cdc3..516f95b 100644 (file)
@@ -1,3 +1,18 @@
+#
+# Copyright (C) 2019 Wind River Systems, Inc.
+#
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
 
 do_install() {
     kerneldir=${D}${KERNEL_SRC_PATH}
@@ -27,6 +42,12 @@ do_install() {
     KBUILD_OUTPUT="$kerneldir"
     oe_runmake -C $kerneldir CC="${KERNEL_CC}" LD="${KERNEL_LD}" clean _mrproper_scripts
 
+    # Clean objtool
+    oe_runmake -C $kerneldir/tools/objtool CC="${KERNEL_CC}" LD="${KERNEL_LD}" clean
+
+    cd $kerneldir
+    ln -sf System.map-* System.map
+
     # make clean generates an absolute path symlink called "source"
     # in $kerneldir points to $kerneldir, which doesn't make any
     # sense, so remove it.