meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-oslo.log_git.bb
diff --git a/meta-stx/recipes-devtools/python/python-oslo.log_git.bb b/meta-stx/recipes-devtools/python/python-oslo.log_git.bb
deleted file mode 100644 (file)
index 0ec652e..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-#
-## Copyright (C) 2019 Wind River Systems, Inc.
-#
-#  Licensed under the Apache License, Version 2.0 (the "License");
-#  you may not use this file except in compliance with the License.
-#  You may obtain a copy of the License at
-#
-#      http://www.apache.org/licenses/LICENSE-2.0
-#
-#  Unless required by applicable law or agreed to in writing, software
-#  distributed under the License is distributed on an "AS IS" BASIS,
-#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-#  See the License for the specific language governing permissions and
-#  limitations under the License.
-
-DESCRIPTION = "Oslo Log Library"
-HOMEPAGE = "https://launchpad.net/oslo"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
-
-SRCREV = "110191aa505cfefafee1c8579213b2f9c3397b6c"
-SRCNAME = "oslo.log"
-PROTOCOL = "https"
-BRANCH = "stable/train"
-S = "${WORKDIR}/git"
-PV = "3.38.0+git${SRCPV}"
-
-SRC_URI = "git://github.com/openstack/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
-
-inherit setuptools
-
-DEPENDS += " \
-        python-pip \
-        python-babel \
-        python-pbr-native \
-        "
-
-# Satisfy setup.py 'setup_requires'
-DEPENDS += " \
-        python-pbr-native \
-        "
-
-# RDEPENDS_default: 
-RDEPENDS_${PN} += " \
-        bash \
-        python-pbr \
-        python-six \
-        python-oslo.config \
-        python-oslo.context \
-        python-oslo.i18n \
-        python-oslo.utils \
-        python-oslo.serialization \
-        python-pyinotify \
-        python-debtcollector \
-        python-dateutil \
-        python-monotonic \
-        "