Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-influxdb_git.bb
diff --git a/meta-stx/recipes-devtools/python/python-influxdb_git.bb b/meta-stx/recipes-devtools/python/python-influxdb_git.bb
new file mode 100644 (file)
index 0000000..ce49699
--- /dev/null
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2019 Wind River Systems, Inc.
+#
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
+SUMMARY = "InfluxDB is an open-source distributed time series database, find more about InfluxDB at https://docs.influxdata.com/influxdb/latest"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=046523829184aac3703a4c60c0ae2104"
+
+SRCREV = "dc83fc6576b6463dcc77a0c101475a2a71ed655a"
+PROTOCOL = "https"
+BRANCH = "master"
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://github.com/influxdata/influxdb-python.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
+
+
+DEPENDS += " python"
+inherit setuptools distutils pkgconfig