openstack-barbican-api: cleanup unused files
[pti/rtp.git] / meta-stx / recipes-devtools / python / python-barbican_git.bb
index 80f3fdf..46aae34 100644 (file)
@@ -88,6 +88,9 @@ do_install_append() {
 
     sed -e "s:%BARBICAN_CONF_DIR%:${sysconfdir}/${SRCNAME}:g" \
         -i ${D}/${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/tests/api/test_resources_policy.py
+
+    install -m 0755 -d ${D}/${sysconfdir}/tmpfiles.d
+    echo "d ${localstatedir}/log/barbican 0750 barbican barbican -" >> ${D}/${sysconfdir}/tmpfiles.d/barbican.conf
 }
 
 USERADD_PACKAGES = "${PN}"
@@ -106,6 +109,7 @@ FILES_${SRCNAME} = "${sysconfdir}/${SRCNAME}/* \
                    ${bindir}/* \
                     ${localstatedir}/* \
                     ${systemd_system_unitdir} \
+                    ${sysconfdir}/tmpfiles.d/barbican.conf \
 "
 
 ALLOW_EMPTY_${SRCNAME}-setup = "1"
@@ -120,11 +124,6 @@ DEPENDS += " \
         python-pip \
         python-pbr-native \
         "
-# Stx config files
-DEPENDS += " \
-       openstack-barbican-api \
-       "
-
 
 RDEPENDS_${SRCNAME} = "${PN} \
                        ${SRCNAME}-setup \
@@ -146,7 +145,6 @@ RDEPENDS_${PN} += " \
         python-pastedeploy \
         python-paste \
         python-pycrypto \
-        python-pysqlite \
         python-keystoneclient \
         python-sqlalchemy \
         python-stevedore \