armada-app: fix build failure on centos
[pti/rtp.git] / meta-stx / recipes-core / stx-openstack-armada-app / openstack-helm_1.0.bb
index 17b1fe0..a43d9f4 100644 (file)
@@ -85,6 +85,7 @@ do_compile () {
 
        # Host a server for the charts
        helm serve --repo-path . &
+       sleep 1
        helm repo rm local
        helm repo add local http://localhost:8879/charts
 
@@ -104,9 +105,8 @@ do_compile () {
        make panko
        make placement
 
-       # terminate helm server
-       pid=`/bin/pidof helm`
-       kill ${pid}
+       # terminate helm server (the last backgrounded task)
+       kill $!
        rm -rf ${helm_home}
 
        # Remove the helm-toolkit tarball