armada-app: fix build failure on centos
[pti/rtp.git] / meta-stx / recipes-core / stx-monitor-armada-app / monitor-helm_1.0.bb
index 78503ac..375c006 100644 (file)
@@ -88,6 +88,7 @@ do_compile () {
 
        # Host a server for the charts
        helm serve --repo-path . &
+       sleep 1
        helm repo rm local
        helm repo add local http://localhost:8879/charts
 
@@ -101,9 +102,8 @@ do_compile () {
        make logstash
        make elasticsearch-curator
 
-       # terminate helm server
-       pid=`/bin/pidof helm`
-       kill ${pid}
+       # terminate helm server (the last backgrounded task)
+       kill $!
        rm -rf ${helm_home}
 }