armada-app: fix build failure on centos
[pti/rtp.git] / meta-stx / recipes-core / stx-monitor-armada-app / monitor-helm-elastic_1.0.bb
index 7cc8dab..1f54f1d 100644 (file)
@@ -81,6 +81,7 @@ do_compile () {
 
        # Host a server for the charts
        helm serve --repo-path . &
+       sleep 1
        helm repo rm local
        helm repo add local http://localhost:8879/charts
 
@@ -88,9 +89,8 @@ do_compile () {
        rm -rf elasticsearch/Makefile
        make elasticsearch
 
-       # terminate helm server
-       pid=`/bin/pidof helm`
-       kill ${pid}
+       # terminate helm server (the last backgrounded task)
+       kill $!
        rm -rf ${helm_home}
 }