platform-kickstarts: add new recipe for generating ks files
[pti/rtp.git] / meta-stx / recipes-core / stx-metal / stx-metal.bb
index b3b9029..26a170c 100644 (file)
@@ -38,16 +38,19 @@ LIC_FILES_CHKSUM = " \
 
 
 SRC_URI = "git://opendev.org/starlingx/metal.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
-               file://0001-mtce-compute-dont-install-empty-directory-unless-nee.patch \
-               file://0001-mtce-control-dont-install-empty-directory-unless-nee.patch \
-               file://0001-mtce-storage-dont-install-empty-directory-unless-nee.patch \
-               file://0001-Use-snprintf-to-avoid-overflowing-amon.tx_buf.patch \
-               file://0001-Use-LDFLAGS-when-linking-and-pass-flags-down-to-subm.patch \
-               file://0001-stx-metal-remove-argparse-requirement-from-inventory.patch \
-               file://stx-warrior-adjust-paths.patch \
-               "
+       file://0001-mtce-compute-dont-install-empty-directory-unless-nee.patch \
+       file://0002-mtce-control-dont-install-empty-directory-unless-nee.patch \
+       file://0003-mtce-storage-dont-install-empty-directory-unless-nee.patch \
+       file://0004-Use-snprintf-to-avoid-overflowing-amon.tx_buf.patch \
+       file://0005-Use-LDFLAGS-when-linking-and-pass-flags-down-to-subm.patch \
+       file://0006-stx-metal-remove-argparse-requirement-from-inventory.patch \
+       file://0007-mtce-do-not-use-which-to-check-CC.patch \
+       file://0008-stx-warrior-adjust-paths.patch \
+       file://0009-pmon_send_pulse.patch \
+       file://0010-libamon-add-shared-option.patch \
+       "
 
-inherit setuptools
+inherit setuptools systemd
 
 
 DEPENDS = " \
@@ -68,7 +71,7 @@ require mtce-control.inc
 require mtce-storage.inc
 require python-inventoryclient.inc
 require pxe-network-installer.inc
-# require kickstart.inc
+require platform-kickstarts.inc
 
 do_configure () {
        :
@@ -90,3 +93,5 @@ FILES_${PN} = " "
 FILES_${PN}-dbg_append += " "
 FILES_${PN}-staticdev_append = " "
 FILES_${PN}-dev_append = " "
+
+DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"