Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-core / stx-integ / ibsh_0.3e.bbappend
diff --git a/meta-stx/recipes-core/stx-integ/ibsh_0.3e.bbappend b/meta-stx/recipes-core/stx-integ/ibsh_0.3e.bbappend
new file mode 100644 (file)
index 0000000..6cd9673
--- /dev/null
@@ -0,0 +1,39 @@
+#
+## Copyright (C) 2019 Wind River Systems, Inc.
+#
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += " \
+       file://${PN}/ibsh-0.3e.patch \
+       file://${PN}/ibsh-0.3e-cgcs.patch \
+       file://${PN}/ibsh-0.3e-cgcs-copyright.patch \
+       file://${PN}/admin.cmds \
+       file://${PN}/admin.xtns \
+       file://${PN}/LICENSE \
+       file://${PN}/operator.cmds \
+       file://${PN}/operator.xtns \
+       file://${PN}/secadmin.cmds \
+       file://${PN}/secadmin.xtns \
+       "
+
+do_install_append() {
+       cp ${WORKDIR}/${PN}/admin.cmds ${D}/${sysconfdir}/ibsh/cmds/
+       cp ${WORKDIR}/${PN}/admin.xtns ${D}/${sysconfdir}/ibsh/xtns/
+       cp ${WORKDIR}/${PN}/operator.cmds ${D}/${sysconfdir}/ibsh/cmds/
+       cp ${WORKDIR}/${PN}/operator.xtns ${D}/${sysconfdir}/ibsh/xtns/
+       cp ${WORKDIR}/${PN}/secadmin.cmds ${D}/${sysconfdir}/ibsh/cmds/
+       cp ${WORKDIR}/${PN}/secadmin.xtns ${D}/${sysconfdir}/ibsh/xtns/
+}
+