stx-ha: cleanup todo and commented lines
[pti/rtp.git] / meta-stx / recipes-core / stx-ha / stx-ha.bb
index cdbdeb3..ae5b0b0 100644 (file)
@@ -22,20 +22,18 @@ SRCREV = "a7b7d35b9922a3f2a8462492b7f1958f135a612d"
 S = "${WORKDIR}/git"
 PV = "1.0.0"
 
-
-#TODO:
-#3b83ef96387f14655fc854ddc3c6bd57  ./LICENSE
-#3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt-api/sm-api/LICENSE
-#3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt-client/LICENSE
-#1dece7821bf3fd70fe1309eaa37d52a2  ./service-mgmt-client/sm-client/LICENSE
-#3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt-tools/sm-tools/LICENSE
-#3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt/LICENSE
-#3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt/sm-common/LICENSE
-#3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt/sm-db/LICENSE
-#3b83ef96387f14655fc854ddc3c6bd57  ./service-mgmt/sm/LICENSE
-
 LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+LIC_FILES_CHKSUM = " \
+       file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+       file://service-mgmt-api/sm-api/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+       file://service-mgmt-client/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+       file://service-mgmt-client/sm-client/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2 \
+       file://service-mgmt-tools/sm-tools/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+       file://service-mgmt/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+       file://service-mgmt/sm-common/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+       file://service-mgmt/sm-db/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+       file://service-mgmt/sm/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+       "
 
 SRC_URI = "git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
        file://0001-Allow-user-to-define-destination-libdir.patch \
@@ -68,7 +66,6 @@ require sm-client.inc
 require sm-tools.inc
 require stx-ocf-scripts.inc
 
-#TODO: Shouldn't have to do this
 LDFLAGS_remove = "-Wl,--as-needed"
 
 do_configure () {
@@ -85,9 +82,6 @@ do_install () {
 
 FILES_${PN} = " "
 FILES_${PN}-dev += " \
-       var/lib/sm/watchdog/modules/libsm_watchdog_nfs.so \
+       ${localstatedir}/lib/sm/watchdog/modules/libsm_watchdog_nfs.so \
        "
-#      var/lib/sm/watchdog/modules/libsm_watchdog_nfs.so.1 \
-#      var/lib/sm/watchdog/modules/libsm_watchdog_nfs.so.0 \
-#      ${libdir}/libsm_common.so.1 \
-#      ${libdir}/libsm_common.so.0 
+