pam-config: add pam_deny module for password
[pti/rtp.git] / meta-stx / recipes-core / stx-config-files / config-files_1.0.0.bb
index 875649d..82d1092 100644 (file)
@@ -51,6 +51,8 @@ SRC_URI = " \
        file://syslog-ng-config-systemd-service.patch \
        file://syslog-ng-conf-replace-match-with-message.patch \
        file://lighttpd-init-script-chroot.patch \
+       file://nfsserver-remvoe-the-f-option-for-rpc.mountd.patch \
+       file://nfsserver.service-add-dependency-on-rpcbind.service.patch \
        "
 
 do_configure () {
@@ -578,6 +580,9 @@ pkg_postinst_ontarget_pam-config() {
        
        cp -f ${datadir}/starlingx/stx.system-auth ${sysconfdir}/pam.d/system-auth
        cp -f ${datadir}/starlingx/sshd.pam    ${sysconfdir}/pam.d/sshd
+
+       sed -i -e '/password .*pam_ldap.so/,/session .*revoke/ s/^$/password required pam_deny.so\n/g' \
+               ${sysconfdir}/pam.d/system-auth
 }
 
 pkg_postinst_ontarget_rabbitmq-server-config() {