stx-ha: add missing dependency in Makefile for libsm_watchdog_nfs
[pti/rtp.git] / meta-stx / recipes-core / stx-config-files / config-files_1.0.0.bb
index da6e623..2002e2d 100644 (file)
@@ -49,7 +49,6 @@ SRC_URI = " \
        file://util-linux-pam-postlogin.patch \
        file://syslog-ng-config-parse-err.patch \
        file://syslog-ng-config-systemd-service.patch \
-       file://syslog-ng-conf-fix-the-source.patch \
        file://syslog-ng-conf-replace-match-with-message.patch \
        file://lighttpd-init-script-chroot.patch \
        "
@@ -69,7 +68,6 @@ do_install () {
                tar -c $f -f - | tar -C ${D}/${datadir}/starlingx/config-files -xf -;
        done
        find ${D}/${datadir}/starlingx/config-files -name centos -exec rm -rf {} +
-       rm -rf ${D}/${datadir}/starlingx/config-files/centos-release-config 
        chown -R root:root ${D}/${datadir}/starlingx/config-files/
 
        # For io-scheduler-config
@@ -80,6 +78,7 @@ do_install () {
 
 PACKAGES ?= ""
 PACKAGES += "audit-config"
+PACKAGES += "centos-release-config"
 PACKAGES += "dhclient-config"
 PACKAGES += "dnsmasq-config"
 PACKAGES += "docker-config"
@@ -111,6 +110,7 @@ PACKAGES += "util-linux-config"
 
 FILES_${PN} = ""
 FILES_audit-config = "${datadir}/starlingx/config-files/audit-config/"
+FILES_centos-release-config = "${datadir}/starlingx/config-files/centos-release-config/"
 FILES_dhclient-config = "${datadir}/starlingx/config-files/dhcp-config/"
 FILES_dnsmasq-config = "${datadir}/starlingx/config-files/dnsmasq-config/"
 FILES_docker-config = "${datadir}/starlingx/config-files/docker-config/"
@@ -146,7 +146,7 @@ RDEPENDS_audit-config += " \
        audit-python \
        "
 RDEPENDS_dhclient-config += "dhcp-client"
-RDEPENDS_dnsmasq-config += ""
+RDEPENDS_dnsmasq-config += "dnsmasq"
 RDEPENDS_docker-config += "docker-ce logrotate "
 RDEPENDS_initscripts-config += "initscripts"
 RDEPENDS_filesystem-scripts += ""
@@ -250,6 +250,13 @@ pkg_postinst_ontarget_audit-config() {
        chmod 640 ${sysconfdir}/audisp/plugins.d/syslog.conf
 }
 
+pkg_postinst_centos-release-config() {
+        sed 's/@PLATFORM_RELEASE@/${ORAN_REL}/' $D${datadir}/starlingx/config-files/centos-release-config/files/issue >> $D${sysconfdir}/issue
+        sed 's/@PLATFORM_RELEASE@/${ORAN_REL}/' $D${datadir}/starlingx/config-files/centos-release-config/files/issue.net >> $D${sysconfdir}/issue.net
+        chmod 644 $D${sysconfdir}/issue
+        chmod 644 $D${sysconfdir}/issue.net
+}
+
 pkg_postinst_ontarget_dhclient-config() {
        SRCPATH=${datadir}/starlingx/config-files/dhcp-config/files
        install -m 0755 -p ${SRCPATH}/dhclient-enter-hooks ${sysconfdir}/dhcp/dhclient-enter-hooks
@@ -499,27 +506,43 @@ pkg_postinst_ontarget_openldap-config() {
        chmod 644 ${systemd_system_unitdir}/slapd
 }
 
-pkg_postinst_ontarget_openssh-config() {
+pkg_postinst_openssh-config() {
 #      %description
 #      package StarlingX configuration files of openssh to system folder.
 
 
-       SRCPATH=${datadir}/starlingx/config-files/openssh-config/files
+       SRCPATH=$D${datadir}/starlingx/config-files/openssh-config/files
 
-       install -m 644 ${SRCPATH}/sshd.service  ${sysconfdir}/systemd/system/sshd.service
-       install -m 644 ${SRCPATH}/ssh_config    ${datadir}/starlingx/ssh_config
-       install -m 600 ${SRCPATH}/sshd_config   ${datadir}/starlingx/sshd_config
+       install -m 644 ${SRCPATH}/sshd.service  $D${sysconfdir}/systemd/system/sshd.service
+       install -m 644 ${SRCPATH}/ssh_config    $D${datadir}/starlingx/ssh_config
+       install -m 600 ${SRCPATH}/sshd_config   $D${datadir}/starlingx/sshd_config
 
        # remove the unsupported and deprecated options
        sed -i -e 's/^\(GSSAPIAuthentication.*\)/#\1/' \
               -e 's/^\(GSSAPICleanupCredentials.*\)/#\1/' \
               -e 's/^\(UsePrivilegeSeparation.*\)/#\1/' \
-              ${datadir}/starlingx/sshd_config
+              $D${datadir}/starlingx/sshd_config
 
-       sed -i -e 's/\(GSSAPIAuthentication yes\)/#\1/' ${datadir}/starlingx/ssh_config
+       sed -i -e 's/\(GSSAPIAuthentication yes\)/#\1/' $D${datadir}/starlingx/ssh_config
        
-       cp -f ${datadir}/starlingx/ssh_config  ${sysconfdir}/ssh/ssh_config
-       cp -f ${datadir}/starlingx/sshd_config ${sysconfdir}/ssh/sshd_config
+       cp -f $D${datadir}/starlingx/ssh_config  $D${sysconfdir}/ssh/ssh_config
+       cp -f $D${datadir}/starlingx/sshd_config $D${sysconfdir}/ssh/sshd_config
+
+       # enable syslog-ng service by default
+       OPTS=""
+       if [ -n "$D" ]; then
+               OPTS="--root=$D"
+       fi
+       if [ -z "$D" ]; then
+               systemctl daemon-reload
+       fi
+
+       systemctl $OPTS enable sshd.service
+
+       if [ -z "$D" ]; then
+               systemctl --no-block restart sshd.service
+       fi
+
 }
 
 pkg_postinst_ontarget_openvswitch-config() {
@@ -663,15 +686,6 @@ pkg_postinst_syslog-ng-config() {
        if [ -z "$D" ]; then
                systemctl --no-block restart syslog-ng.service
        fi
-
-# TODO
-#preun:
-#      %systemd_preun syslog-ng.service 
-#postun:
-#      ldconfig
-#      %systemd_postun_with_restart syslog-ng.service 
-#      systemctl daemon-reload 2>&1 || :
-#      systemctl try-restart 
 }
 
 pkg_postinst_ontarget_systemd-config() {