init-ifupdown: fix the networking service failure
[pti/rtp.git] / meta-stx / recipes-core / init-ifupdown / init-ifupdown_%.bbappend
diff --git a/meta-stx/recipes-core/init-ifupdown/init-ifupdown_%.bbappend b/meta-stx/recipes-core/init-ifupdown/init-ifupdown_%.bbappend
new file mode 100644 (file)
index 0000000..9ebe7bd
--- /dev/null
@@ -0,0 +1,20 @@
+#
+## Copyright (C) 2019 Wind River Systems, Inc.
+#
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
+do_install_append() {
+       sed -i -e 's/^\(auto eth0\)/#\1/' ${D}/etc/network/interfaces
+}
+
+RDEPENDS_${PN} += "ifupdown"