Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-containers / docker / docker-ce_git.bbappend
diff --git a/meta-stx/recipes-containers/docker/docker-ce_git.bbappend b/meta-stx/recipes-containers/docker/docker-ce_git.bbappend
new file mode 100644 (file)
index 0000000..2c96eee
--- /dev/null
@@ -0,0 +1,20 @@
+#
+## Copyright (C) 2019 Wind River Systems, Inc.
+#
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
+do_install_append () {
+       # remove the symlink and create actual dir
+       rm -f ${D}${sysconfdir}/docker
+       install -d -m 0755 ${D}${sysconfdir}/docker
+}