grub: avoid mounting the read-only root filesystem
[pti/rtp.git] / meta-stx / recipes-bsp / grub / grub_2.02.bbappend
index df7354c..cfa2eca 100644 (file)
@@ -20,6 +20,8 @@ do_install_append() {
     for file in ${D}${bindir}/grub2-* ${D}${sbindir}/grub2-*; do
         ln -sf $(basename ${file}) $(echo ${file}|sed 's/grub2/grub/')
     done
+
+    sed -i -e 's/ ro / rw /' ${D}${sysconfdir}/grub.d/10_linux
 }
 
 FILES_${PN}-editenv = "${bindir}/grub2-editenv"