audit: update for stx 5.0
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-security / audit / audit_%.bbappend
index ac32105..421f1ba 100644 (file)
@@ -1,15 +1,12 @@
+inherit stx-metadata
 
-SRCREV_FORMAT = "configfiles"
-SRCREV_configfiles = "d778e862571957ece3c404c0c37d325769772fde"
-
-SRC_URI += "\
-    git://opendev.org/starlingx/config-files.git;protocol=https;branch=r/stx.3.0;destsuffix=stx_configfiles;name=configfiles;subpath=audit-config \
-"
+STX_REPO = "config-files"
+STX_SUBPATH = "audit-config"
 
 do_unpack_append () {
     bb.build.exec_func('do_copy_audit_config', d)
 }
 
 do_copy_audit_config () {
-    cp -f ${WORKDIR}/stx_configfiles/files/syslog.conf ${S}/audisp/plugins/builtins/syslog.conf
+    cp -f ${STX_METADATA_PATH}/files/syslog.conf ${S}/audisp/plugins/builtins/syslog.conf
 }