Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-extended / iptables / iptables_%.bbappend
index f4dee87..96447f2 100644 (file)
@@ -1,25 +1,13 @@
-SRCREV_FORMAT = "opendev"
-SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
-SUBPATH0 = "iptables-config"
-DSTSUFX0 = "stx-configfiles"
+inherit stx-metadata
+
+STX_REPO = "config-files"
+STX_SUBPATH = "iptables-config"
 
 LICENSE_append = "& Apache-2.0"
 LIC_FILES_CHKSUM += "\
-       file://stx-configfiles-LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+       file://${STX_METADATA_PATH}/files/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
        "
 
-SRC_URI += " \
-       git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
-"
-
-do_unpack_append() {
-    bb.build.exec_func('do_copy_config_files', d)
-}
-
-do_copy_config_files () {
-    cp -pf ${WORKDIR}/${DSTSUFX0}/files/LICENSE ${S}/stx-configfiles-LICENSE
-}
-
 inherit systemd
 SYSTEMD_PACKAGES += "${PN}"
 SYSETMD_SERVICE_${PN}_append = "iptables.service ip6tables.service"
@@ -28,6 +16,6 @@ DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
 
 do_install_append() {
     install -d -m0755 ${D}/${sysconfdir}/sysconfig
-    install -m 600 ${WORKDIR}/${DSTSUFX0}/files/iptables.rules ${D}/${sysconfdir}/sysconfig/iptables
-    install -m 600 ${WORKDIR}/${DSTSUFX0}/files/ip6tables.rules ${D}/${sysconfdir}/sysconfig/ip6tables
+    install -m 600 ${STX_METADATA_PATH}/files/iptables.rules ${D}/${sysconfdir}/sysconfig/iptables
+    install -m 600 ${STX_METADATA_PATH}/files/ip6tables.rules ${D}/${sysconfdir}/sysconfig/ip6tables
 }