meta-starlingx: remove the upstream layer
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / python / python-backports-init_1.0.bb
diff --git a/meta-starlingx/meta-stx-integ/recipes-devtools/python/python-backports-init_1.0.bb b/meta-starlingx/meta-stx-integ/recipes-devtools/python/python-backports-init_1.0.bb
deleted file mode 100644 (file)
index 2db0de3..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-
-SUMMARY = "Helper package to avoid backports/__init__.py conflicts"
-DETAIL = "backports packages in python2 suffer from a flaw in the namespace \
-implementation and can conflict with each other. For OE purposes, at least \
-fix the conflicting install of .../site-packages/backports/__init__.py"
-AUTHOR = "Tim Orling <ticotimo@gmail.com>"
-SECTION = "devel/python"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-SRC_URI = "file://backports/__init__.py"
-
-inherit python-dir
-
-# provide to avoid warnings
-do_compile() {
-    :
-}
-
-do_install() {
-    install -d ${D}${PYTHON_SITEPACKAGES_DIR}/backports
-    install ${WORKDIR}/backports/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/backports/
-}
-
-FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/backports/__init__.py"