dhcp: update for stx 5.0
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-connectivity / dhcp / dhcp_%.bbappend
index 53f793f..9e577c1 100644 (file)
@@ -1,17 +1,12 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+inherit stx-metadata
 
-SRCREV_FORMAT = "opendev"
-SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
-SUBPATH0 = "dhcp-config"
-DSTSUFX0 = "stx-configfiles"
+STX_REPO = "config-files"
+STX_SUBPATH = "dhcp-config"
 
-SRC_URI += "\
-       git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
-"
 
 do_install_append () { 
-       install -m 0755 ${WORKDIR}/${DSTSUFX0}/files/dhclient-enter-hooks ${D}/${sysconfdir}/dhcp/dhclient-enter-hooks
-       install -m 0755 ${WORKDIR}/${DSTSUFX0}/files/dhclient.conf ${D}/${sysconfdir}/dhcp/dhclient.conf
+       install -m 0755 ${STX_METADATA_PATH}/files/dhclient-enter-hooks ${D}/${sysconfdir}/dhcp/dhclient-enter-hooks
+       install -m 0755 ${STX_METADATA_PATH}/files/dhclient.conf ${D}/${sysconfdir}/dhcp/dhclient.conf
        ln -rs ${D}/${sysconfdir}/dhcp/dhclient-enter-hooks ${D}/${sysconfdir}/dhclient-enter-hooks
 }