Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-config-files / mlx4-init.bb
index 6a667ab..3fdcf78 100644 (file)
@@ -1,19 +1,16 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 
-SRCREV_FORMAT = "opendev"
-SRCREV_opendev = "d778e862571957ece3c404c0c37d325769772fde"
-SUBPATH0 = "mlx4-config"
+inherit stx-metadata
+
+STX_REPO = "config-files"
+STX_SUBPATH = "mlx4-config"
+
 DSTSUFX0 = "stx-configfiles"
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM += "\
-       file://stx-configfiles-LICENSE;beginline=1;endline=10;md5=b791daf2e53077e3acb71428524a356d \
-       file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10 \
-       "
-
-SRC_URI += " \
-        git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX0};branch="r/stx.3.0";subpath=${SUBPATH0};name=opendev \
-               file://APACHE-2.0.LICENSE \
+       file://${STX_METADATA_PATH}/centos/mlx4-config.spec;beginline=1;endline=10;md5=b791daf2e53077e3acb71428524a356d \
+       file://${STX_METADATA_PATH}/files/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
        "
 
 RDEPENDS_${PN}_append = " bash"
@@ -28,25 +25,16 @@ DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
 do_configure[noexec] = "1"
 do_patch[noexec] = "1"
 
-do_unpack_append() {
-    bb.build.exec_func('do_copy_config_files', d)
-}
-
-do_copy_config_files () {
-    cp -pf ${WORKDIR}/stx-configfiles/centos/mlx4-config.spec ${S}/stx-configfiles-LICENSE
-    cp -pf ${WORKDIR}/APACHE-2.0.LICENSE  ${S}/LICENSE
-}
-
 do_install() {
        install -d -m 0755 ${D}/${sysconfdir}/init.d/
        install -d -m 0755 ${D}/${systemd_system_unitdir}/
        install -d -m 0755 ${D}/${sysconfdir}/goenabled.d/
        install -d -m 0755 ${D}/${bindir}/
 
-       install -m 755 ${WORKDIR}/${DSTSUFX0}/files/mlx4-configure.sh ${D}/${sysconfdir}/init.d/
-       install -m 644 ${WORKDIR}/${DSTSUFX0}/files/mlx4-config.service ${D}/${systemd_system_unitdir}/
-       install -m 555 ${WORKDIR}/${DSTSUFX0}/files/mlx4_core_goenabled.sh ${D}/${sysconfdir}/goenabled.d/
-       install -m 755 ${WORKDIR}/${DSTSUFX0}/files/mlx4_core_config.sh ${D}/${bindir}/
+       install -m 755 ${STX_METADATA_PATH}/files/mlx4-configure.sh ${D}/${sysconfdir}/init.d/
+       install -m 644 ${STX_METADATA_PATH}/files/mlx4-config.service ${D}/${systemd_system_unitdir}/
+       install -m 555 ${STX_METADATA_PATH}/files/mlx4_core_goenabled.sh ${D}/${sysconfdir}/goenabled.d/
+       install -m 755 ${STX_METADATA_PATH}/files/mlx4_core_config.sh ${D}/${bindir}/
 }
 
 FILES_${PN}_append = " ${systemd_system_unitdir}"