meta-starlingx: remove the upstream layer
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppetlabs-rabbitmq_git.bb
diff --git a/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppetlabs-rabbitmq_git.bb b/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppetlabs-rabbitmq_git.bb
deleted file mode 100644 (file)
index 6fc4a0e..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-
-SUMMARY = "Installs, configures, and manages RabbitMQ."
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-PV = "5.6.0"
-SRCREV = "5ac45dedd9b409c9efac654724bc74867cb9233b"
-PROTOCOL = "https"
-BRANCH = "master"
-S = "${WORKDIR}/git"
-
-SRC_URI = "git://github.com/puppetlabs/puppetlabs-rabbitmq;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
-       file://${PN}/Add-gemspec.patch \
-       "
-
-inherit ruby
-
-DEPENDS += " \
-       ruby \
-       facter \
-       "
-
-RDEPENDS_${PN} += " \
-       ruby \
-       facter \
-       puppet \
-       perl \
-       "
-
-RUBY_INSTALL_GEMS = "puppetlabs-rabbitmq-${PV}.gem"
-
-do_install_append() {
-       install -d -m 0755 ${D}/${datadir}/puppet/modules/rabbitmq
-       tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/rabbitmq
-}
-
-FILES_${PN} += " ${datadir}"