puppetlabs-postgresql: update for stx 5.0
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppetlabs-postgresql_git.bbappend
index e9567c0..67cbea3 100644 (file)
@@ -1,8 +1,14 @@
+inherit stx-metadata
+
+STX_REPO = "integ"
+STX_SUBPATH = "config/puppet-modules/puppet-postgresql-${PV}/centos/files"
+
+SRC_URI_STX += " \
+       file://0001-Roll-up-TIS-patches.patch \
+       file://0002-remove-puppetlabs-apt-as-a-requirement.patch \
+       "
 
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 SRC_URI += " \
-       file://${BPN}/0001-Roll-up-TIS-patches.patch \
-       file://${BPN}/0002-remove-puppetlabs-apt-as-a-requirement.patch \
        file://${BPN}/0003-puppetlabs-postgresql-account-for-naming-diffs.patch \
        file://${BPN}/0004-poky-postgresql-updates.patch \
        file://${BPN}/0005-puppetlabs-postgresql-poky.patch \
@@ -10,8 +16,6 @@ SRC_URI += " \
        file://${BPN}/postgresql.service \
        "
 
-#      file://${PN}/0004-postgresql-service-restart-with-systemctl.patch 
-
 RDEPENDS_${PN}_append = " \
        postgresql \
        postgresql-contrib \
@@ -27,7 +31,7 @@ RDEPENDS_${PN}_append = " \
 
 do_install_append() {
        install -d -m0755 ${D}/usr/lib/systemd/system
-       install -m0644 ${WORKDIR}/${PN}/postgresql.service ${D}/usr/lib/systemd/system
+       install -m0644 ${WORKDIR}/${BPN}/postgresql.service ${D}/usr/lib/systemd/system
 }
 
 FILES_${PN}_append = " /usr/lib/systemd/system/postgresql.service"