meta-starlingx: remove the upstream layer
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppetlabs-lvm_git.bb
diff --git a/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppetlabs-lvm_git.bb b/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppetlabs-lvm_git.bb
deleted file mode 100644 (file)
index b961d6f..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-
-SUMMARY = "Provides Puppet types and providers to manage Logical Resource Management (LVM) features."
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
-
-PV = "0.5.0"
-SRCREV = "d0283da637ae24550fb4ba109a48ef8d5d8c8b84"
-PROTOCOL = "https"
-BRANCH = "master"
-S = "${WORKDIR}/git"
-
-SRC_URI = "git://github.com/puppetlabs/puppetlabs-lvm;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
-       file://${PN}/Add-gemspec.patch \
-       "
-
-inherit ruby 
-
-DEPENDS += " \
-       ruby \
-       facter \
-       "
-
-RDEPENDS_${PN} += " \
-       ruby \
-       facter \
-       puppet \
-       perl \
-       "
-
-RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
-
-
-do_install_append() {
-       install -d -m 0755 ${D}/${datadir}/puppet/modules/lvm
-       tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/lvm/
-}
-
-FILES_${PN} += " ${datadir}"