meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppetlabs-inifile.bb
diff --git a/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppetlabs-inifile.bb b/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppetlabs-inifile.bb
new file mode 100644 (file)
index 0000000..503835c
--- /dev/null
@@ -0,0 +1,38 @@
+
+SUMMARY = "Resource types for managing settings in INI files"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.6.0"
+SRCREV = "88bf9868b532ddf556bdb617f67eda9de0b8dc0f"
+PROTOCOL = "https"
+BRANCH = "master"
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://github.com/puppetlabs/puppetlabs-inifile;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
+       file://puppetlabs-inifile/Add-gemspec.patch \
+       "
+
+inherit ruby
+
+DEPENDS += " \
+       ruby \
+       facter \
+       "
+
+RDEPENDS_${PN} += " \
+       ruby \
+       facter \
+       puppet \
+       perl \
+       "
+
+RUBY_INSTALL_GEMS = "puppetlabs-inifile-${PV}.gem"
+
+do_install_append() {
+       install -d -m 0755 ${D}/${datadir}/puppet/modules/inifile
+       tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/inifile
+}
+
+FILES_${PN} += " ${datadir}"