meta-starlingx: remove the upstream layer
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-vlan_git.bb
diff --git a/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppet-vlan_git.bb b/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppet-vlan_git.bb
deleted file mode 100644 (file)
index 084c001..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-
-SUMMARY = "Puppet module for OpenStack Barbican"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=f05b73a1f91c0e30dece85ed11819aca"
-
-PV = "0.1.0"
-SRCREV = "c937de75c28e63fba8d8738ad6a5f2ede517e53d"
-PROTOCOL = "https"
-BRANCH = "master"
-S = "${WORKDIR}/git"
-
-SRC_URI = "git://github.com/derekhiggins/puppet-vlan.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
-       file://${PN}/Add-gemspec.patch \
-       file://${PN}/metadata.json.patch \
-       "
-
-inherit ruby
-
-DEPENDS += " \
-       ruby \
-       facter \
-       "
-
-RDEPENDS_${PN} += " \
-       ruby \
-       facter \
-       puppet \
-       perl \
-       "
-
-RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
-
-do_install_append() {
-       install -d -m 0755 ${D}/${datadir}/puppet/modules/vlan
-       tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/vlan
-}
-
-FILES_${PN} += " ${datadir}"