meta-stx: re-name and re-org to align with upstream
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-oslo_git.bbappend
diff --git a/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppet-oslo_git.bbappend b/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppet-oslo_git.bbappend
new file mode 100644 (file)
index 0000000..db9c263
--- /dev/null
@@ -0,0 +1,15 @@
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI += " \
+       file://puppet-oslo/0001-Remove-log_dir-from-conf-files.patch \
+       file://puppet-oslo/0002-add-psycopg2-drivername-to-postgresql-settings.patch \
+       "
+
+do_install_append () {
+       # fix the name of python-memcached
+       sed -i -e 's/python-memcache\b/python-memcached/' ${D}/${datadir}/puppet/modules/oslo/manifests/params.pp
+}
+
+RDEPENDS_${PN} += "python-memcached"
+
+inherit openssl10