meta-starlingx: remove the upstream layer
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-nssdb_git.bb
diff --git a/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppet-nssdb_git.bb b/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppet-nssdb_git.bb
deleted file mode 100644 (file)
index c4779b2..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-
-SUMMARY = "NSS database Puppet Module"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0409d65ae3bec182108fd45c64bd0ef2"
-
-PV = "1.0.1"
-SRCREV = "2e163a21fb80d828afede2d4be6214f1171c4887"
-PROTOCOL = "https"
-BRANCH = "master"
-S = "${WORKDIR}/git"
-
-SRC_URI = "git://github.com/rcritten/puppet-nssdb.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
-       file://${PN}/Add-gemspec.patch \
-       file://${PN}/metadata.json.patch \
-       "
-
-inherit ruby
-
-DEPENDS += " \
-       ruby \
-       facter \
-       "
-
-RDEPENDS_${PN} += " \
-       ruby \
-       facter \
-       puppet \
-       perl \
-       "
-
-RUBY_INSTALL_GEMS = "puppet-nssdb-${PV}.gem"
-
-do_install_append() {
-       install -d -m 0755 ${D}/${datadir}/puppet/modules/nssdb
-       tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/nssdb
-}
-
-FILES_${PN} += " ${datadir}"