Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-keystone_git.bbappend
index 09fe50c..b24014f 100644 (file)
@@ -1,13 +1,21 @@
+inherit stx-metadata
+
+STX_REPO = "integ"
+STX_SUBPATH = "config/puppet-modules/openstack/${BP}/centos"
+
+SRC_URI_STX += " \
+       file://patches/0001-pike-rebase-squash-titanium-patches.patch \
+       file://patches/0002-remove-the-Keystone-admin-app.patch \
+       file://patches/0003-remove-eventlet_bindhost-from-Keystoneconf.patch \
+       file://patches/0004-escape-special-characters-in-bootstrap.patch \
+       file://patches/0005-Add-support-for-fernet-receipts.patch \
+       file://patches/0006-update-Barbican-admin-secret-s-user-project-IDs-duri.patch \
+       file://patches/0007-update-for-openstackclient-Train-upgrade.patch \
+       "
 
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 SRC_URI += " \
-       file://${PN}/0001-pike-rebase-squash-titanium-patches.patch \
-       file://${PN}/0002-remove-the-Keystone-admin-app.patch \
-       file://${PN}/0003-remove-eventlet_bindhost-from-Keystoneconf.patch \
-       file://${PN}/0004-escape-special-characters-in-bootstrap.patch \
-       file://${PN}/0005-Add-support-for-fernet-receipts.patch \
-       file://${PN}/0007-puppet-keystone-specify-full-path-to-openrc.patch \
-       file://${PN}/0008-params.pp-fix-the-service-name-of-openstack-keystone.patch \
+       file://${BPN}/puppet-keystone-specify-full-path-to-openrc.patch \
+       file://${BPN}/puppet-keystone-params.pp-fix-the-service-name.patch \
        "
 
 do_install_append () {