Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-drbd_git.bbappend
index c89b516..4efa5eb 100644 (file)
@@ -1,15 +1,19 @@
+inherit stx-metadata
 
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += " \
-       file://${PN}/0001-TIS-Patches.patch \
-       file://${PN}/0002-Disable-timeout-for-mkfs-command.patch \
-       file://${PN}/0003-drbd-parallel-to-serial-synchronization.patch \
-       file://${PN}/0004-US-96914-reuse-existing-drbd-cinder-resource.patch \
-       file://${PN}/0005-Add-PausedSync-states-to-acceptable-cstate.patch \
-       file://${PN}/0006-CGTS-7164-Add-resource-options-cpu-mask-to-affine-drbd-kernel-threads.patch \
-       file://${PN}/0007-Add-disk-by-path-test.patch \
-       file://${PN}/0008-CGTS-7953-support-for-new-drbd-resources.patch \
-       file://${PN}/0009-drbd-slow-before-swact.patch \
+STX_REPO = "integ"
+STX_SUBPATH = "config/puppet-modules/${BP}/centos/files"
+
+SRC_URI_STX += " \
+       file://0001-TIS-Patches.patch \
+       file://0002-Disable-timeout-for-mkfs-command.patch \
+       file://0003-drbd-parallel-to-serial-synchronization.patch \
+       file://0004-US-96914-reuse-existing-drbd-cinder-resource.patch \
+       file://0005-Add-PausedSync-states-to-acceptable-cstate.patch \
+       file://0006-CGTS-7164-Add-resource-options-cpu-mask-to-affine-drbd-kernel-threads.patch \
+       file://0007-Add-disk-by-path-test.patch \
+       file://0008-CGTS-7953-support-for-new-drbd-resources.patch \
+       file://0009-drbd-slow-before-swact.patch \
+       file://0010-Format-DRBD-resource-cpu-mask-to-support-64-or-larger-cpus.patch \
        "
 
 inherit openssl10