meta-starlingx: remove the upstream layer
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-boolean_git.bb
diff --git a/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppet-boolean_git.bb b/meta-starlingx/meta-stx-cloud/recipes-support/puppet/puppet-boolean_git.bb
deleted file mode 100644 (file)
index 1c27849..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-
-DESCRIPTION = "Logical Resource Management (LVM) features for Puppet."
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8cbd44f4ffbc81632df22fdd4ae87811"
-
-PV = "1.0.1"
-SRCREV = "22b726dd78b0a60a224cc7054aebbf28e9306f62"
-PROTOCOL = "https"
-BRANCH = "master"
-S = "${WORKDIR}/git"
-
-SRC_URI = "git://github.com/adrienthebo/puppet-boolean;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
-       file://${PN}/Add-gemspec.patch \
-       "
-inherit ruby
-
-DEPENDS += " \
-       ruby \
-       facter \
-       "
-
-RDEPENDS_${PN} += " \
-       ruby \
-       facter \
-       puppet \
-       perl \
-       "
-
-RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
-
-
-do_install_append() {
-       install -d -m 0755 ${D}/${datadir}/puppet/modules/boolean
-       tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/boolean/
-}
-
-FILES_${PN} += " ${datadir}"