python-ansible: add crypto module for stx 5.0
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-devtools / python / python-ansible_%.bbappend
index 2014f06..816c580 100644 (file)
@@ -8,7 +8,12 @@ PV = "2.8.5"
 
 SRCNAME = "ansible"
 
-SRC_URI = "http://releases.ansible.com/ansible/${SRCNAME}-${PV}.tar.gz"
+FILESEXTRAPATHS_prepend := "${THISDIR}/files/${BPN}:"
+
+SRC_URI = " \
+       http://releases.ansible.com/ansible/${SRCNAME}-${PV}.tar.gz \
+       file://python-ansible-crypto.py-allow-the-constraint-value-to-be-lower-cas.patch \
+       "
 
 SRC_URI[md5sum] = "86f0c18250895338709243d997005de3"
 SRC_URI[sha256sum] = "8e9403e755ce8ef27b6066cdd7a4c567aa80ebe2fd90d0ff8efa0a725d246986"
@@ -22,6 +27,7 @@ ANSIBLE_WHITELIST_MODULES = "  \
        cloud \
        clustering \
        commands \
+       crypto \
        database \
        files \
        identity \