go: Add recipes for 1.12 release and make it default
[pti/rtp.git] / meta-oran / recipes-devtools / go / go_1.12.bb
diff --git a/meta-oran/recipes-devtools/go/go_1.12.bb b/meta-oran/recipes-devtools/go/go_1.12.bb
new file mode 100644 (file)
index 0000000..e00d911
--- /dev/null
@@ -0,0 +1,14 @@
+require go-${PV}.inc
+require recipes-devtools/go/go-target.inc
+
+export GOBUILDMODE=""
+
+# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
+# doesn't support -buildmode=pie, so skip the QA checking for mips and its
+# variants.
+python() {
+    if 'mips' in d.getVar('TARGET_ARCH'):
+        d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
+    else:
+        d.setVar('GOBUILDMODE', 'pie')
+}