Upgrade kubernetes version to 1.16.2
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / node-feature-discovery_0.5.0.bb
diff --git a/meta-oran/recipes-containers/kubernetes-plugins/node-feature-discovery_0.5.0.bb b/meta-oran/recipes-containers/kubernetes-plugins/node-feature-discovery_0.5.0.bb
new file mode 100644 (file)
index 0000000..13f638d
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2019 Wind River Systems, Inc.
+#
+
+SUMMARY = "Node feature discovery for Kubernetes"
+DESCRIPTION = "\
+  This software enables node feature discovery for Kubernetes. \
+  It detects hardware features available on each node in a Kubernetes \
+  cluster, and advertises those features using node labels. \
+  \
+  NFD consists of two software components: \
+    - nfd-master is responsible for labeling Kubernetes node objects \
+    - nfd-worker is detects features and communicates them to nfd-master. \
+      One instance of nfd-worker is supposed to be run on each node of the \
+      cluster \
+"
+HOMEPAGE = "https://github.com/kubernetes-sigs/node-feature-discovery"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa"
+
+SRC_URI = "\
+    https://github.com/kubernetes-sigs/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "8130b178e2d5f5aadcec95210b2882d5"
+SRC_URI[sha256sum] = "f351d69e3dbc0e8babe4365e0b5a766cf69e566f89c0191e686f653e17e50b6d"
+
+S = "${WORKDIR}/${BPN}-${PV}"
+
+K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
+
+do_configure() {
+    :
+}
+
+do_compile() {
+    :
+}
+
+do_install() {
+    install -d ${D}${K8S_PLUGINS}
+    install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
+    install -m 644 ${S}/nfd-daemonset-combined.yaml.template ${D}${K8S_PLUGINS}
+    install -m 644 ${S}/nfd-worker.conf.example ${D}${K8S_PLUGINS}
+    install -m 644 ${S}/nfd-worker-job.yaml.template ${D}${K8S_PLUGINS}
+    install -m 644 ${S}/nfd-master.yaml.template ${D}${K8S_PLUGINS}/nfd-master.yaml
+    install -m 644 ${S}/nfd-worker-daemonset.yaml.template ${D}${K8S_PLUGINS}/nfd-worker-daemonset.yaml
+}