stx-ha: add missing dependency in Makefile for libsm_watchdog_nfs
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / node-feature-discovery_0.4.0.bb
index 129a340..7c5b9e4 100644 (file)
@@ -1,6 +1,17 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
 
 SUMMARY = "Node feature discovery for Kubernetes"
 DESCRIPTION = "\
@@ -21,7 +32,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa"
 
 SRC_URI = "\
     https://github.com/kubernetes-sigs/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
-    file://docker-img-nfd-v0.4.0.tar.bz2;unpack=0 \
 "
 
 SRC_URI[md5sum] = "16bcac1d904351a88faa5c6752420ce5"
@@ -29,11 +39,16 @@ SRC_URI[sha256sum] = "c9f826e6c7a42161befc155ca0f465ac5667903e74c857e978a99c7457
 
 S = "${WORKDIR}/${BPN}-${PV}"
 
-PACKAGES =+ "${PN}-img"
-
-DOCKER_IMG = "/opt/docker_images/${BPN}"
 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
 
+do_configure() {
+    :
+}
+
+do_compile() {
+    :
+}
+
 do_install() {
     install -d ${D}${K8S_PLUGINS}
     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
@@ -42,10 +57,4 @@ do_install() {
     install -m 644 ${S}/nfd-worker-job.yaml.template ${D}${K8S_PLUGINS}
     install -m 644 ${S}/nfd-master.yaml.template ${D}${K8S_PLUGINS}/nfd-master.yaml
     install -m 644 ${S}/nfd-worker-daemonset.yaml.template ${D}${K8S_PLUGINS}/nfd-worker-daemonset.yaml
-
-    # Install the saved docker image
-    install -d ${D}${DOCKER_IMG}
-    install -m 644 ${WORKDIR}/docker-img-*.tar.bz2 ${D}${DOCKER_IMG}
 }
-
-FILES_${PN}-img = "${DOCKER_IMG}"