puppet-network: add vlan support for poky-stx.rb
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / multus-cni_3.3.bb
index 6264004..d4b023b 100644 (file)
@@ -1,6 +1,17 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
 
 SUMMARY = "Multus CNI enables attaching multiple network interfaces to pods in Kubernetes."
 DESCRIPTION = "\
@@ -20,8 +31,8 @@ SRC_URI = "\
     https://github.com/intel/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
 "
 
-SRC_URI[md5sum] = "7782df1ea42a8e5a41c71b623080ef2a"
-SRC_URI[sha256sum] = "8b52f9de389d6500be47424ce7876e16d98b9d4547056d666dc588673f1d6842"
+SRC_URI[md5sum] = "fa75272319b19a6192f9d607b79829ea"
+SRC_URI[sha256sum] = "9544fca58e6d1f3943159086651ceb228242b5fd85688bd424d7504c197ec49a"
 
 S = "${WORKDIR}/${BPN}-${PV}"
 
@@ -32,5 +43,6 @@ do_install() {
     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
     install -m 644 ${S}/images/entrypoint.sh ${D}${K8S_PLUGINS}
     install -m 644 ${S}/images/README.md ${D}${K8S_PLUGINS}/README-deployment.md
-    install -m 644 ${S}/images/multus-daemonset-pre-1.16.yml ${D}${K8S_PLUGINS}/multus-daemonset.yml
+    install -m 644 ${S}/images/multus-daemonset-pre-1.16.yml ${D}${K8S_PLUGINS}/multus-daemonset-pre-1.16.yml
+    install -m 644 ${S}/images/multus-daemonset.yml ${D}${K8S_PLUGINS}/multus-daemonset.yml
 }