meta-oran: add missing license header for recipes
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / multus-cni_3.3.bb
index 0ec9d6a..d4b023b 100644 (file)
@@ -1,6 +1,17 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
 
 SUMMARY = "Multus CNI enables attaching multiple network interfaces to pods in Kubernetes."
 DESCRIPTION = "\
@@ -18,7 +29,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
 
 SRC_URI = "\
     https://github.com/intel/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
-    file://docker-img-multus-v3.2.tar.bz2;unpack=0 \
 "
 
 SRC_URI[md5sum] = "fa75272319b19a6192f9d607b79829ea"
@@ -26,9 +36,6 @@ SRC_URI[sha256sum] = "9544fca58e6d1f3943159086651ceb228242b5fd85688bd424d7504c19
 
 S = "${WORKDIR}/${BPN}-${PV}"
 
-PACKAGES =+ "${PN}-img"
-
-DOCKER_IMG = "/opt/docker_images/${BPN}"
 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
 
 do_install() {
@@ -36,11 +43,6 @@ do_install() {
     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
     install -m 644 ${S}/images/entrypoint.sh ${D}${K8S_PLUGINS}
     install -m 644 ${S}/images/README.md ${D}${K8S_PLUGINS}/README-deployment.md
-    install -m 644 ${S}/images/multus-daemonset-pre-1.16.yml ${D}${K8S_PLUGINS}/multus-daemonset.yml
-
-    # Install the saved docker image
-    install -d ${D}${DOCKER_IMG}
-    install -m 644 ${WORKDIR}/docker-img-*.tar.bz2 ${D}${DOCKER_IMG}
+    install -m 644 ${S}/images/multus-daemonset-pre-1.16.yml ${D}${K8S_PLUGINS}/multus-daemonset-pre-1.16.yml
+    install -m 644 ${S}/images/multus-daemonset.yml ${D}${K8S_PLUGINS}/multus-daemonset.yml
 }
-
-FILES_${PN}-img = "${DOCKER_IMG}"